 |
|
 |

DTrace PROGRAMMING WORKSHOP
"Ireland's Centre for Unix Excellence"
DTrace is a comprehensive dynamic tracing framework for the Solaris Operating Environment. DTrace provides a powerful infrastructure to permit administrators, developers, and service personnel to concisely answer arbitrary questions about the behaviour of the operating system and user programs. Course Durations is 3-Days.
- Overview
- Introduction to DTrace
- The "D" Language
- DTrace Mentality
- DTrace Utility
DAY 1
Overview of standard Solaris performance related utilities:
ps, prstat, uptime, vmstat, mpstat, iostat, sar,
netstat, nicstat, kstat, ndd, checkcable, cpustat,
trapstat, truss, sotruss, apptrace, psio, prex,
tnfxtract/tnfdump, adb, mdb
Introduction to DTrace and its possibilities
Using dtrace on the command line
DTrace oneliners: tracing and aggregating
The DTrace mentality: hints for getting started
DAY 2
The 'D' language: its structures and programming possibilities
Examples of programming in 'D'
DTrace recipies: the DTraceToolkit
More DTrace mentality: tricks for fast results
DAY 3
" The DTrace Utility:
The DTrace utility, in the Solaris 10 OS, is one of the most interesting monitoring tools ever made available in a commercial operating system.
With its own D programming language, the DTrace utility can be used to monitor just about all system and application activity on the system.
Target Audience
Students who can benefit from this course are experienced system administrators, service support personnel, kernel developers, and application program developers.
Prerequisites
To succeed fully in this course, students should be able to administer the Solaris 10 Operating System, have a general understanding of the Solaris kernel, and have some programming experience such as Perl or C
|
 |
|
 |